Título

jueves, 26 de mayo de 2011

Fedora 15: Las aplicaciones de 32 bits en un sistema de 64 bits

Como hice hace unos meses con Fedora 14, les traigo la solución a quienes quieren utilizar juegos o cualquier otro programa de 32 bits en su sistema de 64 bits, esta vez en Fedora 15.

Lo único que hay que hacer es escribir lo siguiente en la Terminal (En "Actividades" tipeamos "Terminal", en el caso de GNOME Shell):

su -c 'yum install arts.i686 audiofile.i686 bzip2-libs.i686 cairo.i686 compiz.i686 cyrus-sasl-lib.i686 dbus-libs.i686 directfb.i686 esound-libs.i686 fltk.i686 freeglut.i686 gtk2.i686 hal-libs.i686 imlib.i686 lcms-libs.i686 lesstif.i686 libacl.i686 libao.i686 libattr.i686 libcap.i686 libdrm.i686 libexif.i686 libgnomecanvas.i686 libICE.i686 libieee1284.i686 libsigc++20.i686 libSM.i686 libtool-ltdl.i686 libusb.i686 libwmf.i686 libwmf-lite.i686 libX11.i686 libXau.i686 libXaw.i686 libXcomposite.i686 libXdamage.i686 libXdmcp.i686 libXext.i686 libXfixes.i686 libxkbfile.i686 libxml2.i686 libXmu.i686 libXp.i686 libXpm.i686 libXScrnSaver.i686 libxslt.i686 libXt.i686 libXtst.i686 libXv.i686 libXxf86vm.i686 lzo.i686 mesa-libGL.i686 mesa-libGLU.i686 nas-libs.i686 nss_ldap.i686 cdk.i686 openldap.i686 pam.i686 popt.i686 pulseaudio-libs.i686 sane-backends-libs-gphoto2.i686 sane-backends-libs.i686 SDL.i686 svgalib.i686 unixODBC.i686 zlib.i686 compat-expat1.i686 compat-libstdc++-33.i686 openal-soft.i686 alsa-oss-libs.i686 redhat-lsb.i686 alsa-plugins-pulseaudio.i686 alsa-plugins-oss.i686 alsa-lib.i686 nspluginwrapper.i686 qt-4.7.2-8.fc15.i686 qt-x11-4.7.2-8.fc15.i686'

El comando es muy parecido al de Fedora 14, sólo que con unas adaptaciones a Fedora 15 y el agregado de dos librerías necesarias para utilizar Skype en nuestra distro azul.

Como dije en el artículo de F14, este comando lo creé personalmente tomando como base una lista de librerías (algo incompleta) para Fedora 10/11 de un foro inglés. Lo único que hice fue agregar unas cuantas librerías que me parecían necesarias, y adaptar todas las librerías listadas en dicho foro para las versiones más nuevas de Fedora.

3 comentarios:

  1. Me has SOLUCIONADO LA VIDA! sobre todo con skype. No enserio, gracias :)

    ResponderEliminar
  2. ¡Me alegro de que le sirva a alguien! ¡Gracias por comentarlo!

    ResponderEliminar
  3. otro MUY agradecido, skype anda de lujo.

    pero tengo un juego que ...... no lo puedo hacer andar!!!, es un juego de 32 bits (Machinarium) y a pesar de actualizar la lista de librerias me tira el siguiente error:

    (Machinarium:2371): Gtk-WARNING **: GModule (/usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so) initialization check failed: Gtk+ version too old (micro mismatch)
    Violación de segmento (`core' generado)

    ResponderEliminar